Search in Switchie’s knowledge base

Important: Update PuTTY and FileZilla

Important message regarding PuTTY and FileZilla

If you are currently working with PuTTY in a version lower than 0.71 or with a FileZilla version lower than 3.41.2, you should update the software urgently.
The two updates close a critical security gap that allows attackers to infiltrate malicious code.

More details about the vulnerability can be found Golem.de.

Important: If you do not use PuTTY or FileZilla, you can ignore this message.

Latest Versions

The latest version of PuTTY can be found here: https://www.putty.org/
You can find the latest version of FileZilla here: https://filezilla-project.org/download.php