Chercher dans la base de connaissances de Switchie

Arrêt de versions obsolètes de PHP

Depuis environ 2 mois votre des anciennes versions de PHP dans votre compte utilisateur sont marquées en rouge sous “Administration des produits -> Configuration de base”.

Pour les versions PHP 4, il n’y a plus de support actif ou de sécurité de PHP.net depuis plus de 10 ans. Pour les versions 5 et 7.0 de PHP le support de sécurité a été interrompu il y a 6 mois. Pour PHP 7.1, le soutien actif a pris fin en décembre 2019. Vous pouvez trouver les versions actuelles supportées par php.net et leur roadmap sur le site de php.net.
» https://www.php.net/supported-versions.php

Probablement pas, parce que vous n’utilisez pas un produit WEB actif. Vous pouvez donc ignorer les avertissements rouges. Après avoir éteint les anciennes versions de PHP, elles disparaîtront.

Oui, en tant que client avec un produit WEB actif, vous utilisez très probablement les fonctionnalités de PHP. Si vous ne faites rien, nous activerons une version actuelle de PHP en désactivant l’ancienne version. Si vous utilisez un CMS à jour comme WordPress, Joomla, etc. c’est très probablement compatible. La prudence est de mise, surtout avec une programmation plus ancienne.

Nous vous recommandons de passer à la version 7.3.6 actuelle dès que possible. Si des problèmes surviennent après la conversion, vous avez encore le temps de les résoudre jusqu’à l’arrêt de la conversion.

PHP Version 4
L’Arret du lot débutera le 2 décembre 2019.

PHP Version 5, 7.0 et 7.1
L’Arret du lot débutera le 2. Mars 2020.

Pour changer la version de PHP, veuillez ouvrir les paramètres du domaine concerné dans la configuration de base. Sous Paramètres, vous pouvez sélectionner la version souhaitée dans la liste déroulante. Nous vous recommandons de passer directement à la version 7.3.6.

1. Faites le login dans votre compte utilisateur sur switchplus.ch

2. Sous “Administration des produits” sélectionnez “Configuration de base” et en cliquant avec le bouton droit de la souris sur le domaine, cliquez “Ouvrir”, puis passez à l’onglet “Paramètres”.

3. Ici vous avez un menu de sélection pour la version PHP.
» Après le passage à une version actuelle, l’avertissement disparaît dans la configuration de base.

Si vous ne changez pas la version PHP de votre compte utilisateur à une version PHP actuelle (à partir de 7.2) à l’avance, le système l’automatisera à la date clé.